CrossfireForum.org
Loading
 
Register Photos FAQ Calendar Search Today's Posts Mark Forums Read vBLiveVendor Directory
- CLICK HERE TO GET RID OF THESE ADS -
Go Back   CrossfireForum.org > Technical > Engine & Exhaust

Welcome to Crossfire Forum!
Welcome to Crossfire Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please
join our community today!


Reply
 
 
 
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-21-2010, 03:33 PM
Skyshadow's Avatar
Forum Regular
 
Join Date: Nov 2008
Location: OKC, OK
Age: 26
Posts: 624
Send a message via Yahoo to Skyshadow
Default Help, Engine revs on it's own...


Yesterday My car threw 4 codes; 0400,0402,0171, 0174.
0400 and 0402 are EGR (comes up about every week cause i have no EGR...)
0171 and 0174 are banks 1 and 2 running lean. (never had that code before)
Car was running fine when the codes came up but started running weak (limp mode i believe). After i cleared the codes the car started doing this...
Revving problem video by huffster_2007 - Photobucket
Any help would be great, I'm thinking air leak maybe...

OH, p.s. the brakes have nothing to do with it. I was pressing the brakes because there was a car in front of me... just clarifying.


Black '07 Coupe
TVT Stage 2 Manifold
TVT 3'' intake tubing, MAF and MAF elbow w/ K&N cone filter
TVT Phenolic Spacers
TVT Catch Can
TVT Modified Thermo
TVT Stage 2 injectors
TVT 74mm Throttle Body
TVT EGR/Air pump block plates
ECU Re-tune
Custom Magnaflow exhaust
19" TSW Estarillo w/ Toyo Tires
Smoked Tails
Andrew's Emblems
Eibach Pro-kit Springs
McColluch 6000k H.I.D. lowbeams
5% Tint

http://www.streetfire.net/profile/Skyshadow.htm
Reply With Quote
  #2 (permalink)  
Old 04-21-2010, 05:49 PM
oledoc2u's Avatar
Holliday LLC
 
Join Date: Mar 2008
Location: IN
Age: 60
Posts: 13,468
Default Re: Help, Engine revs on it's own...


Quote:
Originally Posted by Skyshadow
Yesterday My car threw 4 codes; 0400,0402,0171, 0174.
0400 and 0402 are EGR (comes up about every week cause i have no EGR...)
0171 and 0174 are banks 1 and 2 running lean. (never had that code before)
Car was running fine when the codes came up but started running weak (limp mode i believe). After i cleared the codes the car started doing this...
Revving problem video by huffster_2007 - Photobucket
Any help would be great, I'm thinking air leak maybe...

OH, p.s. the brakes have nothing to do with it. I was pressing the brakes because there was a car in front of me... just clarifying.
have you checked to see the manis are tighten down properly....first place to look for an air leak, then make sure every thing is in it's place, hoses, throttle body and such....my guess is the manis....

OK, watched the video...duh....not sure it is manis, since it goes to an idle....although the throttle body may be late in reving down if it is sucking air....

I have never tried this trick on a XF...I use to spray WD 40 to look for throttle leaks on the sports bikes and Harley...you might try this around the seals of the manifolds while the car is running....if it idles up, you are sucking air...leaning a cylinder, which will lead to burning a piston....I will let the others chime in....


'05 Black Xfire #59312 SRT6 Roadster
Needswings Dual CAI-Code 3 SC Pulley-Sprint Booster- LET CustomTune-Needswings Catch Can, R1 Concept drilled rotors,Axxis brake pads, Goodrich brake lines, Castrol SBF, 240 manis, psk, Goodyear F1 GS D3'sb, Wavetrac
12.22ET @ 113.81 Mph (1.74 60')Street tires
'05 Blue xfire #42796 SRT6 Coupe
Needswings Dual CAI-Karmann 62mm SC Pulley-Sprint Booster-Needswings Catch Can-Needswings Manis, Needswings Cooling separation-Eurocharged Tune-wavetrac-psk

Last edited by oledoc2u; 04-21-2010 at 05:56 PM.
Reply With Quote
  #3 (permalink)  
Old 04-21-2010, 09:08 PM
Skyshadow's Avatar
Forum Regular
 
Join Date: Nov 2008
Location: OKC, OK
Age: 26
Posts: 624
Send a message via Yahoo to Skyshadow
Default Re: Help, Engine revs on it's own...


I actually already tried that. I sprayed everywhere on the intake side of my engine. Not one pep of it idling up.


Black '07 Coupe
TVT Stage 2 Manifold
TVT 3'' intake tubing, MAF and MAF elbow w/ K&N cone filter
TVT Phenolic Spacers
TVT Catch Can
TVT Modified Thermo
TVT Stage 2 injectors
TVT 74mm Throttle Body
TVT EGR/Air pump block plates
ECU Re-tune
Custom Magnaflow exhaust
19" TSW Estarillo w/ Toyo Tires
Smoked Tails
Andrew's Emblems
Eibach Pro-kit Springs
McColluch 6000k H.I.D. lowbeams
5% Tint

http://www.streetfire.net/profile/Skyshadow.htm
Reply With Quote
 
Old 04-21-2010, 09:08 PM
Advertisement
Default Re: Help, Engine revs on it's own...


 
 
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:39 PM.




Search Engine Friendly URLs by vBSEO 3.5.2