No - CrossfireForum - The Chrysler Crossfire and SRT6 Resource

Crossfire Coupe A place to discuss Coupe specific topics.

No

Reply

 
 
 
  #1 (permalink)  
Old 06-13-2018, 07:35 PM
spoiler's Avatar
Thread Starter
Join Date: Jul 2015
Location: Fort Collins, Colorado
Posts: 94
Default No

Found this while doing a "fan motor will not blow" search...


"...the fan that blows for the AC, Heat and Defroster just quit working. No matter which mode I put the climate control in, and what level, the fan will not come on. Ideas??



The response to the post was...


1. bad blower motor resistor module.
2. fan clogged with leaf debris.
3. fan motor kaput.
4. A/C control module has the documented connection issue, or is FUBAR.






A month ago, I removed the cowl to unhook the siren which was giving me issues (another thread). The outside drain holes were clogged, cleaned and replaced the cowl. Now the windshield wiper emitters will not squirt (but they do make a noise) and the blower did not operate so no AC and dirty windshield in this heat wave. I checked the 50amp fuses and they appeared okay, meaning they have a little nub in the middle of the wire and it is not melted.
 
Attached Images
File Type: jpg
13 008.jpg (3.69 MB, 18 views)
Reply With Quote
  #2 (permalink)  
Old 06-14-2018, 10:18 AM
spoiler's Avatar
Thread Starter
Join Date: Jul 2015
Location: Fort Collins, Colorado
Posts: 94
Default Re: No

I also checked fuse #15-climate control, auxiliary water pump and fuse #33-climate control
 
Reply With Quote
  #3 (permalink)  
Old 06-14-2018, 10:40 AM
onehundred80's Avatar
Senior Member
Join Date: Apr 2006
Location: Caledon, Ontario
Age: 78
Posts: 20,458
Default Re: No

Originally Posted by spoiler View Post
I also checked fuse #15-climate control, auxiliary water pump and fuse #33-climate control
Could you list your questions? As is, your post is a bit vague, from what I gather the heater fan does not work and the W/washer nozzles do not spray. Did they work prior to your siren fix?
 

Last edited by onehundred80; 06-14-2018 at 10:55 AM.
Reply With Quote
  #4 (permalink)  
Old 06-14-2018, 11:03 AM
spoiler's Avatar
Thread Starter
Join Date: Jul 2015
Location: Fort Collins, Colorado
Posts: 94
Default Re: No

Prior to the siren fix, I had not tried the air conditioner but I had been using the heater all winter and the blower worked fine.

Not sure about the windshield washer emitters as I usually wash the car before I take it out.
 
Reply With Quote
  #5 (permalink)  
Old 06-15-2018, 05:15 PM
spoiler's Avatar
Thread Starter
Join Date: Jul 2015
Location: Fort Collins, Colorado
Posts: 94
Default Re: No

Checked fuse #35-climate control, #36-climate control and #37-circulating air, climate control
 
Reply With Quote
  #6 (permalink)  
Old 06-15-2018, 05:32 PM
Join Date: Mar 2010
Location: Alaska
Posts: 172
Default Re: No

Perhaps the cowl was not reinstalled correctly and is crimping the washer fluid hose. Check under the cowl on the passenger side and you will see a foam gasket that the hose has to work around. Or maybe the hose got pulled off the tank.
 
Reply With Quote
  #7 (permalink)  
Old 06-18-2018, 03:22 PM
spoiler's Avatar
Thread Starter
Join Date: Jul 2015
Location: Fort Collins, Colorado
Posts: 94
Default Re: No

Apparently, the hose located on the passenger side was crimped. I did not know that was a hose, thought it was electrical, which still should not have been in that crimped position.


The AC and fan appear to be working. All I did was insert fuse #9 back into the slot. That should not have cured it.
 
Attached Images
File Type: jpg
18 055.jpg (4.19 MB, 6 views)
Reply With Quote
 
 
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.